zlib problem with Codescape Debugger MIni 7.0

Tagged: 

This topic contains 8 replies, has 2 voices, and was last updated by  Nedu Onuorah 4 years, 9 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #31104

    Hi,

    I cant’t get Codescape Debugger mini 7.0 to run on my linux computer (CentOS 6.3). I keep getting the following error when trying to run the program on terminal:

    “zipimport.ZipImportError: can’t decompress data; zlib not available”
    Fatal Python error: unable to locate initialization module
    Aborted (core dumped)

    After alot of research I found that zlib isnt configured with the default Python-2.6.6 that came with my centos 6.3, but I’m still not able to configure the default Python-2.6.6 to work with zlib.

    p.s. I have already installed zlib-devel package (the other zlib packages were already installed by default)

    Please help!

    let me know if you need more information.

    Thanks.

    #36499

    Sean
    Moderator

    I would expect running the following will install the required components:
    $ yum install zlib.{ARCH}

    {ARCH} can be found using
    $ uname -p

    Codescape does not depend on the installed Python (except for running scripts).

    #36500

    Thanks for your comment Seanr, but I have already installed the zlib component, and I still get the error I mentioned when trying to run the program.

    Anymore suggestions?

    #36501

    Sean
    Moderator

    I am running with CentOS 6.3 without this problem so my questions are to try and understand what is missing on your system.

    Please could you let me know the output of the following commands so I can get a better understanding of your system?
    $ yum list installed | grep zlib
    $ uname -a

    To be clear, are you having trouble running the following (this is the installer):
    $ python Codescape-Debugger-Mini-7.0.1.CentOS-5.4.x86.py

    Do you know what variant of CentOS 6.3 you installed? There are different configurations of packages that are selectable during installation of the OS, the default is minimal.

    #36502

    Yes, I am having trouble running the Codescape Debugger Mini application after installing “Codescape-Debugger-Mini-7.0.1.CentOS-5.4.x86.py”. I am not entirely sure of my OS configurations, but since I didn’t do any configurations during installation I suppose I am on minimal (as that is the default)

    $ yum list installed | grep zlib
    Output:
    zlib.x86_64 1.2.3-27.el6 @base/$releasever
    zlib-devel.x86_64 1.2.3-27.el6 @base
    zlib-static.x86_64 1.2.3-27.el6 @base

    $ uname -a
    Output:
    Linux 37l4247f27-26.eceevl.herts.ac.uk 2.6.32-279.14.1.el6.x86_64 #1 SMP Tue Nov 6 23:43:09 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

    #36503

    Sean
    Moderator

    Ok, sorry to ask you to wait but I’ll get back to you on Monday – I need some time to look into it with the developers.

    #36504

    Okay thats fine. Thanks alot.

    #36505

    Sean
    Moderator

    Sorry for the delay, we have now released a new version of the Codescape Mini debugger (v7.1.9) which is available to download from the Imagination Technologies website. There is a separate 64 bit version available which should resolve the issue you are seeing.

    Please let me know if this resolves your issue.

    #36506

    Thanks for your help Seanr.

Viewing 9 posts - 1 through 9 (of 9 total)
You must be logged in to reply to this topic.